Konfigurasi iBGP di Router Cisco


Pada Kali ini saya akan menyajikan tutorial konfigurasi iBGP di Router Cisco, Sebelumnya saya sudah menjelaskan apa itu BGP dan perbedaan antara Internal BGP dengan Eksternal BGP bagi yang belum paham bisa lihat postingannya disini Apa itu BGP? karena saya disini hanya menjelaskan teknisnya saja

Kita disini memiliki tiga router yang tidak terhubung langsung. kita akan mengkonfigurasi ibgp di antara mereka dan memeriksa jangkauan dari ujung ke ujung.

Pertama-tama, mari kita konfigurasikan interface ketiga router sesuai desain topologi kita.


R1:
interface GigabitEthernet0/0
ip address 10.1.1.1 255.255.255.0
no shutdown
interface GigabitEthernet0/1
ip address 1.1.1.1 255.255.255.252
no shutdown

R2:
interface GigabitEthernet0/1
ip address 1.1.1.2 255.255.255.252
no shutdown
interface GigabitEthernet0/2
ip address 2.2.2.1 255.255.255.252
no shutdown

R3:
interface GigabitEthernet0/2
ip address 2.2.2.2 255.255.255.252
no shutdown
interface GigabitEthernet0/3
ip address 10.2.2.1 255.255.255.0
no shutdown



Setelah mengkonfigurasi IP Address, mari kita konfigurasikan ibgp untuk 3 router ini. Kita juga perlu mengetahui Network 10.1.1.0/24 di router R1 dan Network 10.2.2.0/24 di router R3. 


R1:
R1#configure terminal
R1(config)#router bgp 100
R1(config-router)# network 10.1.1.0 mask 255.255.255.0
R1(config-router)# neighbor 1.1.1.2 remote-as 100

R2:
R2#configure terminal
R2(config)#router bgp 100
R2(config-router)# neighbor 1.1.1.1 remote-as 100
R2(config-router)# neighbor 2.2.2.2 remote-as 100

R3:
R3#configure terminal
R3(config)#router bgp 100
R3(config-router)# network 10.2.2.0 mask 255.255.255.0
R3(config-router)# neighbor 2.2.2.1 remote-as 100


Sekarang, mari kita verifikasi apakah sudah saling terhubung bgp kita menggunakan perintah "show ip bgp summary".

R1:
R1#show ip bgp summary
BGP router identifier 10.1.1.1, local AS number 100
BGP table version is 1, main routing table version 1

Neighbor   V   AS   MsgRcvd   MsgSent   TblVer   InQ   OutQ   Up/Down   State/PfxRcd
1.1.1.2       4   100        5                2              1        0        0       00:00:11            0

R2:
R2#show ip bgp summary
BGP router identifier 2.2.2.1, local AS number 100
BGP table version is 7, main routing table version 7
2 network entries using 288 bytes of memory
2 path entries using 160 bytes of memory
1/1 BGP path/bestpath attribute entries using 152 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 600 total bytes of memory
BGP activity 4/2 prefixes, 4/2 paths, scan interval 60 secs

Neighbor   V   AS   MsgRcvd   MsgSent   TblVer   InQ   OutQ   Up/Down   State/PfxRcd
1.1.1.1       4   100         7                8             7        0        0       00:02:54            1
2.2.2.2       4   100         5                6             7        0        0       00:00:53            1

R3:
R3#show ip bgp summary
BGP router identifier 10.2.2.1, local AS number 100
BGP table version is 1, main routing table version 1

Neighbor   V    AS   MsgRcvd   MsgSent   TblVer   InQ   OutQ   Up/Down   State/PfxRcd
2.2.2.1       4    100          5                 2             1      0        0       00:00:04           0



Jika Anda memeriksanya lebih dekat atau teliti, Kita akan melihat router R1 dan R3 tidak menerima rute apa pun, sedangkan R2 menerima rute dari kedua router. Itu berarti R2 tidak meneruskan rute yang dijangkau itu. Jadi kenapa begitu?

Itu karena, router tidak dapat meng-advertise rute yang dipelajari dari peer ibgp ke peer ibgp lainnya. Ini adalah aturan iBGP untuk menghindari perpecahan horizon. Kita dapat mempelajari lebih lanjut tentang aturan iBGP dari ciscopress .

Jika Kita memiliki Topologi desain mesh penuh, maka masalah ini tidak akan terjadi. Namun, Full mesh tidak selalu memungkinkan dan itu mimpi buruk untuk jaringan yang lebih atau berskala besar. Untuk mengatasinya, kita bisa menggunakan Route Reflectors atau Confederations.

Kita akan membahas dan menerapkannya nanti. Di sini, Anda hanya perlu tahu itu, kita perlu mengkonfigurasi sesi ibgp dengan semua router. Untuk membentuk sesi bgp, kita membutuhkan keterjangkauan dengan rekan kerja. Namun di sini, kita tidak memiliki jangkauan dari R1 ke R3.

R1#ping 2.2.2.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
R1#



Kita tidak memiliki koneksi fisik dari R1 ke R3, jadi kita perlu mengkonfigurasi protokol IGP (OSPF, EIGRP, dll.) Di jaringan ini agar dapat dijangkau.

R1:
R1#configure terminal
R1(config)#router ospf 1
R1(config-router)#network 1.1.1.0 0.0.0.3 area 0

R2:
R2#configure terminal
R2(config)#router ospf 1
R2(config-router)# network 1.1.1.0 0.0.0.3 area 0
R2(config-router)# network 2.2.2.0 0.0.0.3 area 0

R3:
R3#configure terminal
R3(config)#router ospf 1
R3(config-router)# network 2.2.2.0 0.0.0.3 area 0



Pada titik ini, kita memiliki jangkauan dari R1 hingga R3. Mari konfigurasikan ibgp dari R1 ke R3.

R1:
R1#configure terminal
R1(config)#router bgp 100
R1(config-router)# neighbor 2.2.2.2 remote-as 100

R3:
R3#configure terminal
R3(config)#router bgp 100
R3(config-router)# neighbor 1.1.1.1 remote-as 100


Sampai tahap sini sudah selesai masing masing router sudah dapat menjangkau rute

R1#show ip bgp summary
BGP router identifier 10.1.1.1, local AS number 100
BGP table version is 6, main routing table version 6
2 network entries using 288 bytes of memory
2 path entries using 160 bytes of memory
2/2 BGP path/bestpath attribute entries using 304 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 752 total bytes of memory
BGP activity 2/0 prefixes, 2/0 paths, scan interval 60 secs

Neighbor   V   AS   MsgRcvd   MsgSent   TblVer  InQ   OutQ   Up/Down   State/PfxRcd
1.1.1.2       4   100     350            349           6         0       0        05:14:22          0
2.2.2.2       4   100      26              25            6         0       0        00:17:00          1
R1#



Jika kita memeriksa rute bgp kita dari R1, maka kita akan dapat melihat 10.2.2.0/24 di tabel routing kita, yang terdapat dari ibgp peer.


R1#sh ip bgp
BGP table version is 6, local router ID is 10.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
            r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
            x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

    Network           Next Hop      Metric     LocPrf     Weight      Path
*> 10.1.1.0/24       0.0.0.0              0         327            68             i
*>i 10.2.2.0/24      2.2.2.2             0         100             0              i

R1#

 


Terakhir, lakukan ping dari R1 LAN (10.1.1.10) ke R3 LAN (10.2.2.10).

R1#ping 10.2.2.10
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.2.2.10, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/10/26 ms
R1#

 Hasil di atas membuktikan bahwa Kita berhasil menyelesaikan konfigurasi iBGP 

Click here to Download